Recorder Chrome Extension - Missing from Chrome Store
Incident Report for StoryXpress
Resolved
The issue has been resolved with the Chrome Store, and the extension is available for download again.
Posted Nov 25, 2021 - 13:29 UTC
Identified
We have identified an issue with our Chrome Store listing and are working with the Chrome Webstore team to resolve it.
Posted Nov 18, 2021 - 08:10 UTC